disParity » General Discussion

Update freezing, nothing in log

(5 posts)

Tags:

  1. rust0r
    Member

    Hi Roland,

    Just had a problem I've run into the past few days, there was about 100gb of random files I had added to disparity a week or so back but have now deleted and tried running an update. It has gotten stuck several times, often with a popup error (after I click cancel) saying that multiple drives "are not connected". When I check the log there is literally nothing there besides it trying to update the file it was stuck on and then my cancel request.

    It will start out normally, Removing that 1 file from the specific drive, while "Reading" all other files on the other drives, then suddenly all other drives go back to "Update Required" and progress stops on the "Removing" drive.

    The log is of absolutely no help as there's no exceptions of any kind, it literally goes "Removing <file>" and will sit there for hours until I cancel it.

    I have tried a hash check, however it obviously just comes up in error afterwards stating the file no longer exists on the drive.

    My only thought is these files came from a very corrupt hard drive, could it be disparity is having a hard time reading them (they added just fin however)

    Thanks again!

    Posted 9 months ago #
  2. rust0r
    Member

    The odd thing I just found, if I navigate the drives while it is "stalled" it begins to activate and remove things for a few more minutes and then stalls out again.

    Could this be MOBO/HD/Sata cable related ?

    Posted 9 months ago #
  3. Roland
    Roland

    It sounds to me like one of your other drives (not the one that you deleted files from) is going bad.

    When you run an update after deleting files, disParity has to re-calculate from scratch all the parity blocks that overlap with the deleted files. The reason is that the deleted files are gone, so it can't just read them and XOR them with the parity data, like it does when you add new files. To re-calculate the affected blocks, it has to re-read all the files on the other drives that overlap with the deleted files.

    When a drive is starting to go bad, one of the ways that this can manifest is in very, very long access times. Like, a minute or more just to start reading a file. The reason for this is that when the drive encounters an error while reading a file, it will keep retrying to read the file again and again for quite a long time before finally giving up. If it gives up, the drive letter will sometimes vanish completely from Windows, and not come back until you reboot. I've had this happen on several 2TB drives over the last year or so.

    So, it sounds to me like one of your other drives is going bad, and this is causing the update to grind almost completely to a halt while it keeps trying to read files from that drive in order to complete the update.

    There is no error message within disParity itself with the words "are not connected", so I assume what's happening is that Windows is generating this error when the drive finally gives up, passing it up to disParity, and disParity is just displaying it in a generic dialog.

    Now you have to figure out which drive is going bad. It's not the one with the deleted files on it, because that drive is not even being read during the update, so it must be one of the others in your backup. You could try running an individual hashcheck on each one, and see which one either takes forever to finish, or fails outright. Do this by right-clicking on each drive and choosing "Hashcheck". After each drive finishes, move on to the next. Don't use the "Hashcheck All" button because that hashchecks all drives simultaneously and it might not be clear which drive is the troublemaker if you do that.

    Posted 9 months ago #
  4. rust0r
    Member

    Hi Roland,

    Thanks for the response, sorry for my late reply. I've been trying over the past few weeks to sus out the issue. I rebuilt disparity from scratch one drive at a time and believed to have found the failing drive. I was able to copy all of the files to the new drive from the source thankfully; and then added that drive to parity without a hitch.

    Onto my new/next issue, I'm seeing random "Error reading <FILE>: the device is not connected." scattered throughout the logs on add/deletes when updating parity. I have around 20 drives and it doesn't seem to be targeting any specific one at this point.

    Is there something larger at play here? Possibly my motherboard going bad ? Sata card? Power? (I use the common Supermicro 8 SATA SAS PCI-E cards) (I know this is out of the realm of disparity assistance but just wanted to get your thoughts and input).

    Thank you again for your time.

    Posted 8 months ago #
  5. Roland
    Roland

    Since the error message "the device is not connected" is coming from Windows, not disParity, it does sound like your system is having some kind of general drive I/O issue. I really can't speculate as to what it might be, it's just not possible to say based on scattered file access errors.

    Posted 7 months ago #

RSS feed for this topic

Reply

You must log in to post.